Diginews: Sessions-Problem

Liebe Digis,

es gibt ein technisches Problem, ihr habt vielleicht gemerkt, dass das Digi einen halben Tag lang nicht lief. Ich stehe seit gestern abend mit dem Support unseres Hosters in Kontakt, habe gerade fast eine Stunde lang mit einem Mitarbeiter dort telefoniert.

Konkret: Die Digi-Software legt im Root-Ordner meines Accounts sogenannte sessions-Dateien (“Cookies”) an, die nicht wieder gelöscht werden. Mit jedem einzelnen Aufruf, also jedes Mal, wenn jemand die Seite aufruft oder irgendwohin klickt, kommt eine neue Datei hinzu. Diese Dateien müssten eigentlich von selbst wieder verschwinden. Es waren im Laufe der Zeit so viele hunderttausende dieser Dateien zusammengekommen, dass das System völlig ausgebremst worden war.

Sowohl der Support als auch ich waren ziemlich ratlos dahingehend, woran das liegen kann. Die Dateien sind jetzt alle von Hand gelöscht worden, aber das ist ja keine dauerhafte Lösung, das immer so zu machen. Es sammeln sich ja immer neue an.

Der Vorschlag dies Supports war, das Digi komplett neu aufzusetzen, vorher die alten Einträge vorher zu speichern und dann auf der frischen Installation die alten Einträge wieder einzuspielen. Davor schrecke ich zurück, das wäre echt ne heikle Angelegenheit. Vorher könnte ich noch probieren, einzelne Plugins einzeln abzuschalten und zu schauen, ob es dann wieder funktioniert. Das ist zwar auch ein bisschen heikel, aber nicht ganz so sehr. Ich würde das mal in Angriff nehmen. Das kann aber bedeuten, dass bestimmte Einzelbestandteile des Digis nicht funktionieren werden. Bin jetzt am Wochenende daheim und habe ein bisschen Zeit und werde das in Angriff nehmen, und hoffe, auf diese Weise den Fehler zu finden.

Falls jemand von Euch sich ein bisschen auskennt mit WordPress und Cookies (Sessions) oder eine Idee hat, was ich probieren könnte, oder jemanden kennt, der sich damit auskennt, dann wäre ich sehr dankbar, wenn ihr mir auf irgendeine Weise helfen könntet.

Liebe Grüße

Digiadmin

PS: Wir mussten auch ein Backup einspielen, weil die .htaccess Datei verändert worden war, um php-Versionen zu testen, und aus diesem Grund das gesamte System lahmgelegt hat. (Wir wussten nicht, dass es nur an der .htaccess liegt und haben das gesamte Verzeichnis + Datenbank eingespielt). Ich hoffe, dass in der Zwischenzeit keine Einträge gemacht wurden, die dann jetzt weg wären.

2
Hinterlasse einen Kommentar

2 Kommentar Themen
0 Themen Antworten
0 Follower
 
Kommentar, auf das am meisten reagiert wurde
Beliebtestes Kommentar Thema
2 Kommentatoren
WandaLyssa Letzte Kommentartoren

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.

  Abonnieren  
neueste älteste
Benachrichtige mich bei
Lyssa
Mitglied

Können wir dich irgendwie unterstützen?

Wanda
Mitglied

Ich habe leider übethaupt keine Ahnung… Aber um so mehr freue ich mich über dein Angagement 😉